-

Can I still use PCI DSS 2.0 after 31st Dec 2014?

No. As from 1st January 2015 all merchants must report their compliance using PCI DSS Version 3.0.